基于labview的转速测量 LAB3EIGRP2实验

1 实验拓扑:

基于labview的转速测量 LAB3EIGRP2实验(1)

2 实验要求:

1>.配置基本eigrp。

2>.避免所有设备向不必要的接口发送EIGRP报文。

3>.要求总部收到的分部的路由条目尽可能少。

4>.要求实现分部访问internet服务器(80.80.80.80),实现负载分担,internet路由器不得参加eigrp。

5>.R3和R4之间使用md5认证。

6>.配置R5为stub区域,且只能发送直连和汇总路由。

3 实验步骤和实验总结:

0>.基础配置。

Router(config)#hostname R1

R1(config)#int e0/0

R1(config-if)#ip add 12.1.1.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#exit

R1(config)#int e0/1

R1(config-if)#ip add 13.1.1.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#exit

R1(config)#int e0/2

R1(config-if)#ip add 202.100.1.1 255.255.255.252

R1(config-if)#no shutdown

R1(config-if)#exit

Router(config)#hostname R2

R2(config)#int s1/0

R2(config-if)#ip add 25.1.1.2 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#int e0/0

R2(config-if)#ip add 12.1.1.2 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#exit

Router(config)#hostname R3

R3(config)#int e0/1

R3(config-if)#ip add 34.1.1.3 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)#exit

R3(config)#int s1/0

R3(config-if)#ip add 35.1.1.3 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)#exi

R3(config)#int e0/0

R3(config-if)#ip add 13.1.1.3 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)#exit

Router(config)#hostname R4

R4(config)#int e0/0

R4(config-if)#ip add 34.1.1.4 255.255.255.0

R4(config-if)#no shutdown

R4(config-if)#exit

Router(config)#hostname R5

R5(config)#int s1/1

R5(config-if)#ip add 35.1.1.5 255.255.255.0

R5(config-if)#no shutdown

R5(config-if)#exit

R5(config)#int s1/0

R5(config-if)#ip add 25.1.1.5 255.255.255.0

R5(config-if)#no shutdown

R5(config-if)#exit

R5(config)#int loopback 0

R5(config-if)#ip add 172.16.144.1 255.255.255.0

R5(config-if)#exit

R5(config)#int loopback 1

R5(config-if)#ip add 172.16.145.1 255.255.255.0

R5(config-if)#int loopback 2

R5(config-if)#ip add 172.16.146.1 255.255.255.0

R5(config-if)#int loopback 3

R5(config-if)#ip add 172.16.147.1 255.255.255.0

R5(config-if)#exit

Router(config)#hostname R6

R6(config)#int e0/0

R6(config-if)#ip add 202.100.1.2 255.255.255.252

R6(config-if)#no shutdown

R6(config-if)#exit

R6(config)#int loopback0

R6(config-if)#ip add 80.80.80.80 255.255.255.255

R6(config-if)#exit

1>.配置基本eigrp。

R4(config)#router eigrp 90

R4(config-router)#no auto-summary

R4(config-router)#network 34.1.1.0 0.0.0.255

R4(config-router)#exit

R3(config)#router eigrp 90

R3(config-router)#network 13.1.1.0 0.0.0.255

R3(config-router)#network 34.1.1.0 0.0.0.255

R3(config-router)#network 35.1.1.0 0.0.0.255

R3(config-router)#no auto-summary

R3(config-router)#exit

R5(config)#router eigrp 90

R5(config-router)#no auto-summary

R5(config-router)#network 25.1.1.0 0.0.0.255

R5(config-router)#network 35.1.1.0 0.0.0.255

R5(config-router)#network 172.16.144.0 0.0.0.255

R5(config-router)#network 172.16.145.0 0.0.0.255

R5(config-router)#network 172.16.146.0 0.0.0.255

R5(config-router)#network 172.16.147.0 0.0.0.255

R5(config-router)#exit

R1(config)#router eigrp 90

R1(config-router)#no auto-summary

R1(config-router)#network 12.1.1.0 0.0.0.255

R1(config-router)#network 13.1.1.0 0.0.0.255

R1(config-router)#exit

R2(config)#router eigrp 90

R2(config-router)#no auto-summary

R2(config-router)#network 12.1.1.0 0.0.0.255

R2(config-router)#network 25.1.1.0 0.0.0.255

R2(config-router)#exit

2>.避免所有设备向不必要的接口发送eigrp报文。

因为只有R5设置了loopback0口,所以只设置R5的loopback口为passive端口。

R5(config)#router eigrp 90

R5(config-router)#passive-interface loopback0

R5(config-router)#passive-interface loopback1

R5(config-router)#passive-interface loopback2

R5(config-router)#passive-interface loopback3

R5(config-router)#exit

3>.要求总部收到的分部的路由条目尽可能少。

汇总前:

R1(config)#do show ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter areaN1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static routeo - ODR, P - periodic downloaded static route, H - NHRP, l - LISPa - application route - replicated route, % - next hop override, p - overrides from PfRGateway of last resort is not set12.0.0.0/8 is variably subnetted, 2 subnets, 2 masksC 12.1.1.0/24 is directly connected, Ethernet0/0L 12.1.1.1/32 is directly connected, Ethernet0/013.0.0.0/8 is variably subnetted, 2 subnets, 2 masksC 13.1.1.0/24 is directly connected, Ethernet0/1L 13.1.1.1/32 is directly connected, Ethernet0/125.0.0.0/24 is subnetted, 1 subnetsD 25.1.1.0 [90/2195456] via 12.1.1.2, 00:02:29, Ethernet0/034.0.0.0/24 is subnetted, 1 subnetsD 34.1.1.0 [90/307200] via 13.1.1.3, 00:03:28, Ethernet0/135.0.0.0/24 is subnetted, 1 subnetsD 35.1.1.0 [90/2195456] via 13.1.1.3, 00:03:28, Ethernet0/1172.16.0.0/24 is subnetted, 4 subnetsD 172.16.144.0 [90/2323456] via 13.1.1.3, 00:02:29, Ethernet0/1[90/2323456] via 12.1.1.2, 00:02:29, Ethernet0/0D 172.16.145.0 [90/2323456] via 13.1.1.3, 00:02:29, Ethernet0/1[90/2323456] via 12.1.1.2, 00:02:29, Ethernet0/0D 172.16.146.0 [90/2323456] via 13.1.1.3, 00:02:29, Ethernet0/1[90/2323456] via 12.1.1.2, 00:02:29, Ethernet0/0D 172.16.147.0 [90/2323456] via 13.1.1.3, 00:02:29, Ethernet0/1[90/2323456] via 12.1.1.2, 00:02:29, Ethernet0/0202.100.1.0/24 is variably subnetted, 2 subnets, 2 masksC 202.100.1.0/30 is directly connected, Ethernet0/2L 202.100.1.1/32 is directly connected, Ethernet0/2

汇总:

R5(config)#int s1/0

R5(config-if)#ip summary-address eigrp 90 172.16.144.0/20

R5(config-if)#int s1/1

R5(config-if)#ip summary-address eigrp 90 172.16.144.0/20

R5(config-if)#exit

汇总后:

R1(config)#do show ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter areaN1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static routeo - ODR, P - periodic downloaded static route, H - NHRP, l - LISPa - application route - replicated route, % - next hop override, p - overrides from PfRGateway of last resort is not set12.0.0.0/8 is variably subnetted, 2 subnets, 2 masksC 12.1.1.0/24 is directly connected, Ethernet0/0L 12.1.1.1/32 is directly connected, Ethernet0/013.0.0.0/8 is variably subnetted, 2 subnets, 2 masksC 13.1.1.0/24 is directly connected, Ethernet0/1L 13.1.1.1/32 is directly connected, Ethernet0/125.0.0.0/24 is subnetted, 1 subnetsD 25.1.1.0 [90/2195456] via 12.1.1.2, 00:08:55, Ethernet0/034.0.0.0/24 is subnetted, 1 subnetsD 34.1.1.0 [90/307200] via 13.1.1.3, 00:09:54, Ethernet0/135.0.0.0/24 is subnetted, 1 subnetsD 35.1.1.0 [90/2195456] via 13.1.1.3, 00:09:54, Ethernet0/1172.16.0.0/20 is subnetted, 1 subnetsD 172.16.144.0 [90/2323456] via 13.1.1.3, 00:00:37, Ethernet0/1[90/2323456] via 12.1.1.2, 00:00:37, Ethernet0/0202.100.1.0/24 is variably subnetted, 2 subnets, 2 masksC 202.100.1.0/30 is directly connected, Ethernet0/2L 202.100.1.1/32 is directly connected, Ethernet0/2

4>.要求实现分部访问internet服务器(80.80.80.80),实现负载分担,internet路由器不得参加eigrp。

R1(config)#ip route 0.0.0.0 0.0.0.0 202.100.1.2

R1(config)#router eigrp 90

R1(config-router)#redistribute static

R1(config-router)#exit

R6(config)#ip route 0.0.0.0 0.0.0.0 202.100.1.1

R5#ping 80.80.80.80

Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 80.80.80.80, timeout is 2 seconds:!!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 10/10/11 ms

静态路由重分布之后路由已经等价负载。

R5(config)#do show ip route eigrp

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter areaN1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static routeo - ODR, P - periodic downloaded static route, H - NHRP, l - LISPa - application route - replicated route, % - next hop override, p - overrides from PfRGateway of last resort is 35.1.1.3 to network 0.0.0.0D*EX 0.0.0.0/0 [170/2221056] via 35.1.1.3, 00:01:23, Serial1/1[170/2221056] via 25.1.1.2, 00:01:23, Serial1/012.0.0.0/24 is subnetted, 1 subnetsD 12.1.1.0 [90/2195456] via 25.1.1.2, 00:15:17, Serial1/013.0.0.0/24 is subnetted, 1 subnetsD 13.1.1.0 [90/2195456] via 35.1.1.3, 00:15:12, Serial1/134.0.0.0/24 is subnetted, 1 subnetsD 34.1.1.0 [90/2195456] via 35.1.1.3, 00:15:12, Serial1/1172.16.0.0/16 is variably subnetted, 9 subnets, 3 masksD 172.16.144.0/20 is a summary, 00:07:12, Null0

以下步骤将0.0.0.0路由的等价负载变更为非等价负载:

R5(config)#access-list 1 permit 0.0.0.0 255.255.255.255

R5(config)#router eigrp 90

R5(config-router)#offset-list 1 in 30 s1/1

R5(config-router)#exit

R5(config)#do show ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter areaN1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static routeo - ODR, P - periodic downloaded static route, H - NHRP, l - LISPa - application route - replicated route, % - next hop override, p - overrides from PfRGateway of last resort is 25.1.1.2 to network 0.0.0.0D*EX 0.0.0.0/0 [170/2221056] via 25.1.1.2, 00:00:05, Serial1/012.0.0.0/24 is subnetted, 1 subnetsD 12.1.1.0 [90/2195456] via 25.1.1.2, 00:00:05, Serial1/013.0.0.0/24 is subnetted, 1 subnetsD 13.1.1.0 [90/2195486] via 35.1.1.3, 00:00:05, Serial1/125.0.0.0/8 is variably subnetted, 2 subnets, 2 masksC 25.1.1.0/24 is directly connected, Serial1/0L 25.1.1.5/32 is directly connected, Serial1/034.0.0.0/24 is subnetted, 1 subnetsD 34.1.1.0 [90/2195486] via 35.1.1.3, 00:00:05, Serial1/135.0.0.0/8 is variably subnetted, 2 subnets, 2 masksC 35.1.1.0/24 is directly connected, Serial1/1L 35.1.1.5/32 is directly connected, Serial1/1172.16.0.0/16 is variably subnetted, 9 subnets, 3 masksD 172.16.144.0/20 is a summary, 00:26:15, Null0C 172.16.144.0/24 is directly connected, Loopback0L 172.16.144.1/32 is directly connected, Loopback0C 172.16.145.0/24 is directly connected, Loopback1L 172.16.145.1/32 is directly connected, Loopback1C 172.16.146.0/24 is directly connected, Loopback2L 172.16.146.1/32 is directly connected, Loopback2C 172.16.147.0/24 is directly connected, Loopback3L 172.16.147.1/32 is directly connected, Loopback3

R5(config)#router eigrp 90

R5(config-router)#variance 10

R5(config-router)#exit

R5(config)#do show ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter areaN1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static routeo - ODR, P - periodic downloaded static route, H - NHRP, l - LISPa - application route - replicated route, % - next hop override, p - overrides from PfRGateway of last resort is 35.1.1.3 to network 0.0.0.0D*EX 0.0.0.0/0 [170/2221086] via 35.1.1.3, 00:00:09, Serial1/1[170/2221056] via 25.1.1.2, 00:00:09, Serial1/012.0.0.0/24 is subnetted, 1 subnetsD 12.1.1.0 [90/2221086] via 35.1.1.3, 00:00:09, Serial1/1[90/2195456] via 25.1.1.2, 00:00:09, Serial1/013.0.0.0/24 is subnetted, 1 subnetsD 13.1.1.0 [90/2195486] via 35.1.1.3, 00:00:09, Serial1/1[90/2221056] via 25.1.1.2, 00:00:09, Serial1/025.0.0.0/8 is variably subnetted, 2 subnets, 2 masksC 25.1.1.0/24 is directly connected, Serial1/0L 25.1.1.5/32 is directly connected, Serial1/034.0.0.0/24 is subnetted, 1 subnetsD 34.1.1.0 [90/2195486] via 35.1.1.3, 00:00:09, Serial1/1[90/2246656] via 25.1.1.2, 00:00:09, Serial1/035.0.0.0/8 is variably subnetted, 2 subnets, 2 masksC 35.1.1.0/24 is directly connected, Serial1/1L 35.1.1.5/32 is directly connected, Serial1/1172.16.0.0/16 is variably subnetted, 9 subnets, 3 masksD 172.16.144.0/20 is a summary, 00:00:09, Null0C 172.16.144.0/24 is directly connected, Loopback0L 172.16.144.1/32 is directly connected, Loopback0C 172.16.145.0/24 is directly connected, Loopback1L 172.16.145.1/32 is directly connected, Loopback1C 172.16.146.0/24 is directly connected, Loopback2L 172.16.146.1/32 is directly connected, Loopback2C 172.16.147.0/24 is directly connected, Loopback3L 172.16.147.1/32 is directly connected, Loopback3

R5(config)#do show ip route 0.0.0.0

Routing entry for 0.0.0.0/0, supernetKnown via "eigrp 90", distance 170, metric 2221056, candidate default path, type externalRedistributing via eigrp 90Last update from 35.1.1.3 on Serial1/1, 00:01:49 agoRouting Descriptor Blocks:35.1.1.3, from 35.1.1.3, 00:01:49 ago, via Serial1/1Route metric is 2221086, traffic share count is 1Total delay is 22002 microseconds, minimum bandwidth is 1544 KbitReliability 255/255, minimum MTU 1500 bytesLoading 1/255, Hops 2* 25.1.1.2, from 25.1.1.2, 00:01:49 ago, via Serial1/0Route metric is 2221056, traffic share count is 1Total delay is 22000 microseconds, minimum bandwidth is 1544 KbitReliability 255/255, minimum MTU 1500 bytesLoading 1/255, Hops 2

5>.R3和R4之间使用md5认证。

R4(config)#key chain glab

R4(config-keychain)#key 1

R4(config-keychain-key)#key-string glab

R4(config-keychain-key)#exit

R4(config-keychain)#exit

R4(config)#int e0/0

R4(config-if)#ip authentication key-chain eigrp 90 glab

R4(config-if)#ip authentication mode eigrp 90 md5

R4(config-if)#exit

R3(config)#key chain glab1

R3(config-keychain)#key 1

R3(config-keychain-key)#key-string glab

R3(config-keychain-key)#exit

R3(config-keychain)#exit

R3(config)#int e0/1

R3(config-if)#ip authentication key-chain eigrp 90 glab1

R3(config-if)#ip authentication mode eigrp 90 md5

R3(config-if)#ex

R4(config)#do show ip eigrp neighbors

EIGRP-IPv4 Neighbors for AS(90)H Address Interface Hold Uptime SRTT RTO Q Seq(sec) (ms) Cnt Num0 34.1.1.3 Et0/0 10 00:00:37 9 100 0 32

6>.配置R5为stub区域,且只能发送直连和汇总路由。

R5(config)#router eigrp 90

R5(config-router)#eigrp stub

R5(config-router)#do show running | se eigrp

ip summary-address eigrp 90 172.16.144.0 255.255.240.0ip summary-address eigrp 90 172.16.144.0 255.255.240.0router eigrp 90network 25.1.1.0 0.0.0.255network 35.1.1.0 0.0.0.255network 172.16.144.0 0.0.0.255network 172.16.145.0 0.0.0.255network 172.16.146.0 0.0.0.255network 172.16.147.0 0.0.0.255passive-interface Loopback0passive-interface Loopback1passive-interface Loopback2passive-interface Loopback3eigrp stub connected summary

4.作业中遇到的问题:

,

免责声明:本文仅代表文章作者的个人观点,与本站无关。其原创性、真实性以及文中陈述文字和内容未经本站证实,对本文以及其中全部或者部分内容文字的真实性、完整性和原创性本站不作任何保证或承诺,请读者仅作参考,并自行核实相关内容。文章投诉邮箱:anhduc.ph@yahoo.com

    分享
    投诉
    首页